99 7.3 7qts low on oil - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-21-2009, 08:30 AM
Powerstroke.org Rookie
 

Join Date: Dec 2009
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
99 7.3 7qts low on oil

I recently had a high pressure oil pump o-ring go bad on my 99 7.3. I had it towed to Bob Sight Ford and they repaired it. When I picked it up, I asked the service adviser how much oil I had lost. He said he wasnt sure, but not to worry about it. After driving it about 100 miles, the engine shuttered, then stopped running all together. Long story short. The dealership never checked my oil after the repair and allowed me to drive off of their lot 7 qts. low on oil. Now I am having a hard time getting it started. It seems to run ok once it does start, but sometimes I have to cycle the glow plugs 3 times to get it to start. Ford says this is "normal" and not to worry about it. They say they are sorry, but they aren't interested in doing any additional work on it because "it will be fine." Any and all suggestions and ideas are welcome. Thanks in advance.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 12-21-2009, 08:42 AM
Powerstroke.org Sponsor

 

Join Date: Jan 2009
Location: Hillsborough, NC
Posts: 1,011
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I'm guessing that you topped off the oil before you ran it any more. If you have to cycle the GP 3 times to start, you do have some sort of problem. Try adding a bottle of Lucas oil additive to the oil and see if that helps. If your oil is full don't worry about overfilling while adding the Lucas, a little extra in the crankcase will not hurt anything. What temps. are you seeing overnight?
Reply With Quote Quick reply to this message
  #3  
Old 12-21-2009, 08:45 AM
Compression Ignition Addict
 

Join Date: Oct 2008
Location: Batavia, Ohio
Posts: 2,597
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Send a message via AIM to BIGBILL105 45
Quote:
Originally Posted by greasltn View Post
I'm guessing that you topped off the oil before you ran it any more. If you have to cycle the GP 3 times to start, you do have some sort of problem. Try adding a bottle of Lucas oil additive to the oil and see if that helps. If your oil is full don't worry about overfilling while adding the Lucas, a little extra in the crankcase will not hurt anything. What temps. are you seeing overnight?
Don't use an oil additive to a HEUI injection.
Reply With Quote Quick reply to this message
  #4  
Old 12-21-2009, 09:00 AM
Powerstroke.org Rookie
 

Join Date: Dec 2009
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by greasltn View Post
I'm guessing that you topped off the oil before you ran it any more. If you have to cycle the GP 3 times to start, you do have some sort of problem. Try adding a bottle of Lucas oil additive to the oil and see if that helps. If your oil is full don't worry about overfilling while adding the Lucas, a little extra in the crankcase will not hurt anything. What temps. are you seeing overnight?
I sits in the garage. So I'm gonna guess about 60 degrees.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 01:44 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors