CPS replaced but still runs rough 97 F350 - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 7 Old 03-23-2007, 05:51 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Sep 2006
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
CPS replaced but still runs rough 97 F350

I bought the "BLUE" Cps and replaced it but it still throws the "Intermiittant CPS" code, the truck will start and the Tach will move accordingly when pressing the pedal, but it runs really rough and the CEL comes on about one second after starting, during that one second the truck sounds normal, all other functons are normal (wait to start etc..) ANY Help would be great I'm stumped and so is my mechanic. What ELSE could it be....as you guys know I'm losing money when I don't have my truck to get to jobs that pay me.. Thanks.
Justgreasenofries is offline  
post #2 of 7 Old 03-24-2007, 07:46 AM
Serving Our Country!
 
gregor's Avatar
 
Join Date: Nov 2006
Location: elmendorf afb alaska
Posts: 486
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
I can't really help you with your problem so I figure that I will bump the thread up for you.

2006 F-150 Supercrew
Cold air intake
Dual exhaust
Alpine stereo


[/QUOTE]
gregor is offline  
post #3 of 7 Old 03-24-2007, 07:52 AM
BIG TRUCK, SMALL DRIVER
 
pipelayerjdh's Avatar
 
Join Date: Oct 2006
Location: Iva, SC
Posts: 5,877
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
can you pull the codes?

May be a bad or loose wire. Try checking the connectors going in to the valve covers.

Derrick

My photobucket




'97 F-350 "FORDOR" 4X4 (Dually Conversion, Shackle Reversal, Technicooler , Auto Meter Gauges, 4" DIY Dual Exhaust w/ '08 tips, 4" DIY intake w/ AEM filter, Wicked Wheel 2, 360 thrust bearing, Homemade E-fuel conversion, Wildman Chip, 160cc DIY injectors , DIY IDM mod) 230K and counting...
pipelayerjdh is offline  
post #4 of 7 Old 03-26-2007, 03:29 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Sep 2006
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
I checked all the plugs going into the valve covers, no melting a little dirty on the out side bit no obvious problems. This sucks!
Justgreasenofries is offline  
post #5 of 7 Old 03-26-2007, 04:12 AM
ADMIN AND TECH


 
SCUFFY828's Avatar
 
Join Date: Oct 2006
Location: winston salem north carolina
Posts: 9,316
Thanks: 0
Thanked 11 Times in 11 Posts
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Feedback Score: 0 reviews
need to pull codes and go from there

SCUFFY828@POWERSTROKE.ORG
ITS STOCK
SCUFFY828 is offline  
post #6 of 7 Old 03-26-2007, 09:41 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Sep 2006
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
The code still indicates "intermittant CPS" do you know where to buy shims for the cps? I read that it might need a shim. Randall.:blowup:
Justgreasenofries is offline  
post #7 of 7 Old 03-26-2007, 09:52 AM
ADMIN AND TECH


 
SCUFFY828's Avatar
 
Join Date: Oct 2006
Location: winston salem north carolina
Posts: 9,316
Thanks: 0
Thanked 11 Times in 11 Posts
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Feedback Score: 0 reviews
i dont see the shim being your problem ,very well may have gotten a bad cps out the box ,that does happen , see if they well warranty a cps for you

SCUFFY828@POWERSTROKE.ORG
ITS STOCK
SCUFFY828 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome