03 6.0 no power,white smoke - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 2 Old 11-27-2009, 07:25 AM Thread Starter
Powerstroke.org Rookie
Join Date: Nov 2009
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
03 6.0 no power,white smoke

Hey, i am new to the forum and have a problem that i need some immediate help with.i have a 2003 6.0 with 135k.Engine starts good and idles good.upon putting in drive and powering up it has no power/accleration to get to next gear,will not exceed 30/40 mph,it also during this time of accleration emitts white smoke from exhaust like crazy.Have changed both fuel filters and oil and checked air filters all good.I have had turbo changed 2 times prior at 40k and 100k under warranty and symptons are a little different this time?egr cooler was mentioned but i am not losing coolant at all,actually just had to change w.pump pulley due to it cracked around hub and coolant level was full before broke apart and after and running for weeks.i actually have to put tow haul on to get truck to 30/40 mph or truck will not even get past 20?Also floored once and heard a loud POP sound and thought something broke loose,almost like a backfire?nothing changed though.help.
co2009 is offline  
Sponsored Links
post #2 of 2 Old 11-29-2009, 04:11 AM
powerstroke trayback's Avatar
Join Date: Jul 2008
Location: bundaberg Australia
Posts: 43
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
suggest you dont drive or start it as what you describe sounds like turbo. check all the rubber hoses on intercooler & turbo for wear, splits and clamps tight. if all ok check turbo itself. heaps of white smoke indicates turbo problem
good luck

2005 7.3 ltr,(we still got them in 2005)
6spd zf,southbend clutch.
Driven Diesel fuel system, Cat filters
Custom air intake
Tunes by Wildman
powerstroke trayback is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome