03 7.3 Bat light on, something is not shutting off - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 11-19-2009, 08:17 AM Thread Starter
Powerstroke.org Rookie
Join Date: Nov 2009
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
03 7.3 Bat light on, something is not shutting off

I have an 03 with a 7.3 A month ago I replaced the alternator (old one burned up) and batteries. I am assuming that my current problem burned up the old alternator. My battery light is staying on for a long time in the mornings. It will go off after 10 to 15 miles but seems like it is taking longer. I tested the alternator while idling and something was making it put out 40 amps. If I have to make several short trips it will drain the batteries/ I think maybe the glow plug circuit is staying on, does this make sense?
IMRICH is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome