Powerstroke runnung bad - Ford Powerstroke Diesel Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 11-09-2009, 03:53 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Nov 2009
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Powerstroke runnung bad

Not really sure where to start, but at times, my RPMs fluctuate. Yesterday while driving home with the cruise set, it felt like it was laggin at times. Also when I'm sittin at a stop sign or something, it goes crazy. Today my old lady was like what the hell is goin on. I just changed the fuel filter, so I know it's not that. I read somewhere it could be the EGR valve, whatever that is. But yesterday was the first time it lagged like that with the cruise control on. I didn't lose any speed, but you could definately feel something is going on. Any ideas? Thanks

No check engine light what so ever. It's an 06 XLT with the 6.0 powerstroke.
bay_slayer is offline  
post #2 of 3 Old 11-13-2009, 05:43 PM
Member
 
Join Date: Nov 2009
Posts: 55
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
check you exhaust back pressure sensor. it's located on top a tube coming up from the driver's side exh manifold. removed it and make sure the pipe is clear also make sure the sensor is clean and dry.


Travis G.
International Tech is offline  
post #3 of 3 Old 11-14-2009, 08:01 PM
Powerstroke.org Rookie
 
Join Date: Nov 2009
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by bay_slayer View Post
Not really sure where to start, but at times, my RPMs fluctuate. Yesterday while driving home with the cruise set, it felt like it was laggin at times. Also when I'm sittin at a stop sign or something, it goes crazy. Today my old lady was like what the hell is goin on. I just changed the fuel filter, so I know it's not that. I read somewhere it could be the EGR valve, whatever that is. But yesterday was the first time it lagged like that with the cruise control on. I didn't lose any speed, but you could definately feel something is going on. Any ideas? Thanks

No check engine light what so ever. It's an 06 XLT with the 6.0 powerstroke.
Hi bay-slayer; I have an 06 King Ranch, at 162k my tach started to bounce had hesitation when under load and poor fuel economy. problem turned out to be # 1 and 2 injectors were shot. $2000.00 later it ran great. The only real way to find out anything with these trucks is get a code reader or get the dealer to read it for you. Good luck
k lauritsen is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome