Loosing all the coolant - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 10-30-2009, 10:35 PM Thread Starter
Powerstroke.org Rookie
Join Date: Apr 2009
Posts: 11
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Loosing all the coolant, PLEASE HELP

I am having a problem with our 07 6.0 with 42000 miles and cant tell what the problem is, either HG or EGR cooler. It keeps loosing all the coolant from the resivor when you drive it. Like a 80 mile round trip will use a gallon of coolant. There is no coolant in the oil, temp stays good, and it runs normal. It started when we were pulling our travel trailer back home and under a load (like going up hill) the cab would smell like antifreeze bad. any insite on where to start looking for problems. Also under the hood, right above the resivor tank cap, it is all whit, like it has been sprayed with antifreeze. Possible that the cap is just bad. Me and the truck are stuck at a trailer park 3 hours away from a mechanic, so Im kust trying small fixes my self before it is towed home


2007 F-250
8" fabtech 4.0 coil-over lift with steering stab.
8" skyjacker leaf springs with blocks
20x12 RBP wheels
37/13.50/20 Nittos
full audio and navi
train horns

Last edited by turbo4vL; 10-30-2009 at 11:00 PM.
turbo4vL is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome