Edge Juice w/ Attitude harness - Ford Powerstroke Diesel Forum
Edge Products Edge Productsl

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-13-2012, 12:33 PM
Powerstroke.org Rookie
 

Join Date: Mar 2012
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Edge Juice w/ Attitude harness

I need one of the adapters that comes with the Edge Juice w/ attitude setup. It's the blue harness adapter that comes connected to the harness. The part number is 9000600-02.

If anyone has one sitting around from a kit that went bad, please let me know. I'd be interested in buying it.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 11-12-2012, 12:54 PM
Powerstroke.org Rookie
 

Join Date: May 2010
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I'm looking for the same. I just contact Edge products to see if they will sell it. I'm guessing they won't if you are posting it here.

Is yours physically damaged, or did you just have some open connections? My glow plugs won't fire when I have my harness installed, and I've traced it down to an "open" on the number 3 pin of this connector. I'm probably just going to splice and bypass the connector to make this work again.

Before I knew it was the pin in this connector, I called Edge Products and they just wanted me to replace the whole package with a new one for at a discounted price of $600 (of course).

I finally got them to admit it as the harness causing the problem, so I've been drilling down to the root of the problem since. I'm tempted to crack open the connector, but not sure I can do anything on the inside and worried I will cause more damage.
Reply With Quote Quick reply to this message
  #3  
Old 11-12-2012, 01:32 PM
Powerstroke.org Rookie
 

Join Date: Mar 2012
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I finally found someone with a whole box of edge modules for the 6.0. I bought the whole box so I could use the blue connector I needed. Now I have a spare black one too. Is your unit the one with the blue and black adapters? I have a couple of the harnesses for the older versions that didn't use the blue and black 2-1 adapters.

Mine had an open connection that if you wiggled it would make contact. I tried taking the unit apart, but the foam/epoxy sealant in between the boards made it practically impossible to fix. If you could find a chemical that could disolve it without damaging the circuit board, you could reflow the solder connections, but I didn't find anything that would do that.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 01:33 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors