Slow to build boost. - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-21-2014, 12:34 PM
Powerstroke.org Rookie
 

Join Date: Sep 2009
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Slow to build boost.

I just installed my gauges and I cannot build any boost until I reach 1700 rpms and under a load. At that point will build 5 to 6psi. this is on my Swamp tuner on stock. I have the Swamp 175/146 injectors. Set on highest it will build up to 26 psi at full load. EGT will get to 1400 pretty quick. I've never run gauges before and it just surprised me no boost untill 1700 rpms. Is this normal? I can foresee a issue as soon as I pull a heavy load with my EGT? Thanks
Early 99, 25Swamp 175/146 injectors, swamps 5,000 miles. tunes. 4" exhaust, Swamps air cleaner. Adreian HPOP[/COLOR], Boost & EGT Gauges. 5 Speed.___[/COLOR]
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 08-21-2014, 03:56 PM
Compression Ignition Addict
 

Join Date: Oct 2011
Location: Chico, California
Posts: 3,339
Thanks: 14
Thanked 89 Times in 85 Posts
Feedback Score: 0 reviews
sounds like you have some sort of boost leak?

check the up pipes and intercooler/manifold boots.

are you running the stock e99 turbo?
Reply With Quote Quick reply to this message
  #3  
Old 08-21-2014, 04:07 PM
Powerstroke.org Rookie
 

Join Date: Sep 2009
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Yes It's stock. Swamps told me that the WW2 would fit on the E99?? I am going to replace the tubo pedestal this weelend because of an oil leak, I will replace my up pipes then. With 25 lbs of boost I am surprised that the up pipes were leaking but cause its on the pressure side I can see that now.
Reply With Quote Quick reply to this message
  #4  
Old 08-22-2014, 06:11 AM
Powerstroke.org Rookie
 

Join Date: Sep 2009
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
My main question is does all of these tubo's not build any boost untill 1700 rpm then with a small load on it?
Reply With Quote Quick reply to this message
  #5  
Old 08-22-2014, 03:12 PM
Compression Ignition Addict
 

Join Date: Oct 2011
Location: Chico, California
Posts: 3,339
Thanks: 14
Thanked 89 Times in 85 Posts
Feedback Score: 0 reviews
the ww2 will help with spool up, and yes it will work. plus more boost/power/lower egts. from what i remember the stock e99 turbos spooled really quick. that leads me to believe you have a leak somewhere.

when my up pipes were leaking i could get 25 but that was it. after i fixed them it was a huge difference.
Reply With Quote Quick reply to this message
The Following User Says Thank You to blue99stroker For This Useful Post:
hucorey (08-22-2014)
  #6  
Old 08-22-2014, 05:18 PM
Powerstroke.org Rookie
 

Join Date: Sep 2009
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Thanks, I will know tomorrow,
Reply With Quote Quick reply to this message
  #7  
Old 08-24-2014, 04:41 PM
Powerstroke.org Rookie
 

Join Date: Sep 2009
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I guess that 1700 rpms with a load is normal to start boost? I replaced my turbo pedestal yesterday along with new up pipes and a wicked wheel two and no leaks were found and my boost range has not changed, same as before. And the oil leak that I was trying to stop is still there. It appears that thge rear main is leaking.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 06:29 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors