Front hub leaking grease, new seal? - Ford Powerstroke Diesel Forum

 
LinkBack Thread Tools Display Modes
post #1 of 1 Old 09-18-2011, 07:42 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Dec 2010
Posts: 24
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Front hub leaking grease, new seal?

I'm not familiar with 4WD so hopefully this is a no-brainer for those that are.

This is an early 99 250 w/ 268k miles on it.

I was at the tire store getting some new tires installed and the tech mentioned that there is grease leaking out of the front hub on the passenger side. It is a small amount of grease but he said if I didn't replace the hub seal and re-grease it then I could lose the whole front axle.

So I wanted to know; is his diagnosis correct?

And is this so urgent that I shouldn't drive it at all until I fix it?

I don't know how long it has been leaking.

Thanks!
New2PSD is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome