early 99 ABS valve - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-20-2010, 12:46 PM
Hate stupid people

 
Join Date: Apr 2008
Location: West Lafayette, in
Posts: 5,666
Thanks: 0
Thanked 26 Times in 25 Posts
Feedback Score: 0 reviews
Question early 99 ABS valve

determined my abs valve isn't allowing my brake fluid to release my front brakes fully, any idea if the early 99's are the same as 99+s because i know the 01's are different? any good place to buy one?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 02-20-2010, 02:28 PM
Hate stupid people

 
Join Date: Apr 2008
Location: West Lafayette, in
Posts: 5,666
Thanks: 0
Thanked 26 Times in 25 Posts
Feedback Score: 0 reviews
bump
Reply With Quote Quick reply to this message
  #3  
Old 06-23-2011, 04:47 PM
Powerstroke.org Rookie
 

Join Date: Jun 2011
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
bum any luck im having the same problems and i just ordered at new hydro boost. all four of mine r locking up though
Reply With Quote Quick reply to this message
  #4  
Old 06-23-2011, 05:13 PM
Compression Ignition Addict
 

Join Date: Nov 2010
Location: Kansas
Posts: 240
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
My door code says I have 4 wheel ABS plus I have an ABS light in the cluster, but there is nothing going to my brakes as far as wires/sensors etc. I don't have ESOF either, there is a rubber cap on what looks like where the vacuum line would go. So you guys do actually have ABS?
Reply With Quote Quick reply to this message
  #5  
Old 06-24-2011, 02:42 PM
Powerstroke.org Fanatic
 

Join Date: Nov 2007
Location: Oakland, OR
Posts: 124
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
when I took apart the front end to do new ball joints I don't remember any tone rings or wiring for abs on the front at all, just the spot where the esof line would connect, mine's got manual hubs. I thought we just had rear wheel abs, but could be mistaken?
Reply With Quote Quick reply to this message
  #6  
Old 11-27-2011, 02:08 PM
Powerstroke.org Fanatic
 

Join Date: Mar 2011
Location: Braintree
Posts: 105
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
i had the same problem after fixing many things to no end i fixed the prob by flushing the fluid in the power steering pump that was 6 months ago has not done it once since give it a shot cant hurt
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 03:47 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors