Truck will not start - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 02-17-2010, 08:09 PM Thread Starter
Member
 
Riverboyxlt's Avatar
 
Join Date: Jan 2010
Location: ATX
Posts: 64
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Truck will not start

Ok 03/99 F350 will not start. Drove it to work, drove around at lunch. After work no start. Clicks but no rotation of starter. Thought maybe I left my phones car charger plugged in pulled out the Edge and read a P0603 code. Researched on here and it was really I throw away code I seemed to gather, but the batteries were old anyway. So 2 brand new batteries were put in. Truck will still not start. Just click and nothing. I'm brand new to electrical to diesels so I went to Advanced and asked for a starter relay since the little black box drive side engine bay clicked and had 2 relays inside. After a 15 minutes explination on how diesels did not have these, he hands me a universal selenoid. I told the guy if these are what is wrong the truck has 2 of them on the top of the motor, another 20 mintues of him "teaching me" he said only one on the firewall. I walked out of their store.

Any input on what can be the cause of the trucks problem?
Riverboyxlt is offline  
post #2 of 3 Old 02-18-2010, 11:56 AM
Compression Ignition Addict
 
Nosparkplugs's Avatar
 
Join Date: Apr 2008
Location: East central IL
Posts: 218
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Sounds like ur starters junk. Before you do anything tho clean all your electrical connections on the batteries and starter. If that doesnt help take your starter off and test it. Ive been through several starters but never had that solenoid go out. The solenoid on top of the motor you are refering to is the glow plug solenoid not the starting solenoid

Early 99 f-250 cab and half longbed 4" intake and exhaust edge evolution II(for egt and boost guage only), trans temp guage trucool max 40K, TW 6 pos
Nosparkplugs is offline  
post #3 of 3 Old 02-18-2010, 07:42 PM Thread Starter
Member
 
Riverboyxlt's Avatar
 
Join Date: Jan 2010
Location: ATX
Posts: 64
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
I think yo may be right, I hav free towing on my insurance so I got it towed literally 1 mile to the dealer. After unloading it from the wrecker it started right up and has ever since. I probably will get a new starter and change it this weekend.
Riverboyxlt is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome