2005 E-350 6.0L Intermittant problems. - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 09-19-2011, 01:16 PM Thread Starter
Powerstroke.org Rookie
Join Date: Sep 2011
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
2005 E-350 6.0L Intermittant problems.

Hey anyone: I have some intermittant problems with my powerstoke that the dealer has not fixed. First I have a long crank sometimes that seems to be random, check engine light comes on & it has the camshaft sensor code. which was changed. They also changed my batteries telling me maybe the engine wasnt spinning fast enough.

Second and this is recent it has been almost dying while driving, going to just under idle & staying that way for about a minute or so then slowly going back to normal. It has also been soft starting compared to the explosion it would make when new.
I was told it could be the lift pump.
If it is the lift pump does anyone have a location & part number they could give me.
Sound like the pump may be part of the water seprerator on the rail under the driver is this so?
Thanks in advance.
surfnmrf is offline  
Sponsored Links

6.0 l psd problems, 6.0l diesel van, powerstoke van

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome