03 E250 Fuel Pump Problem - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 08-17-2010, 08:38 PM Thread Starter
Powerstroke.org Rookie
FireStroker88's Avatar
Join Date: Aug 2010
Location: Poplar Grove, IL
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
03 E250 Fuel Pump Problem

Ok guys looking for some help here. I am racking my brain against the wall over and over again! This is not a 7.3 by the way, the is a 5.4L Gas motor. Here's the scenario on my way to a job the other morning and without any warning the van dies, will crank over but does not start. Waited 5 minutes started right up and ran fine to the job. Went to start it up and it cranked, and cranked, waited 5 min fired up, drove to my garage and when i shut it off it would not start back up. I have no power to the fuel pump after checking with a meter. I know the fuel pump works because when I jump it, it runs fine. I have checked all the fueses, Relays are fine, I have checked the insura switch. Can anyone give me any direction on what to check next? Is there a test for the PCM? Thanks in advance!
FireStroker88 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome