rear leaf spring u bolts loose - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 06-14-2009, 07:46 PM Thread Starter
Join Date: Sep 2008
Posts: 54
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
rear leaf spring u bolts loose

i noticed a bunch of clacking and banging around in the back of my truck for the last month or 2 and wrote it off to the ford flap on the back of the tail gate...til i checked it yesterday and realised the u bolts clamping my leaf springs together on the rear passenger side was way loose and that its actually wearing away at the center rod. sorry if i dont know the names of everything going on back there..needless to say these nuts dont loosen in the least bit, or where do i go from here.... what could have caused this???
texazranger07 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome