abs speed sensor issue - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 11-14-2011, 01:35 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Sep 2011
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
abs speed sensor issue

my 2005 ford f350 diesel recently the speedometer started acting up , i would be driving and the gauge would cut out and all of the sudden jump back up, i hooked up my programmer to read the trouble code in which it showed speed sensor error. so i bought the part at ford installed it my self and the speedometer is still not working along with the abs light being on too. im not sure what else to do with it. any suggestions
drtystroker2005 is offline  
post #2 of 3 Old 07-18-2013, 04:54 PM
Powerstroke.org Rookie
 
willedriver's Avatar
 
Join Date: Nov 2010
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Smile Speedometer not working

I'm having the same problem with my 2000 F350. Yesterday the speedometer quit and at the same time the ABS light came on and on the shift lever (auto) the light that comes on if you shut off the overdrive is blinking. I can't get it in any shop for a week and of course company is coming tomorrow and family reunion about 100 miles away. And of course the cruise control doesn't work.
willedriver is offline  
post #3 of 3 Old 07-18-2013, 07:30 PM
Serving Our Country!
 
JSchuricht's Avatar
 
Join Date: Aug 2007
Location: Manor, TX
Posts: 2,975
Thanks: 0
Thanked 27 Times in 26 Posts
Mentioned: 1 Post(s)
Quoted: 0 Post(s)
Feedback Score: 2 reviews
You should have started a new thread. Plan on not taking your truck to the reunion unless you can fix the issue before hand. There are several systems that rely on the speed signal, your automatic transmission is one so don't drive it except to see if the issue is fixed.

The system is fairly simple, there is a tone ring attached to the carrier in the rear differential. The VSS counts the teeth and sends a square wave signal to the cluster. The cluster then passes the signal to the ABS and PCM which controls your transmission. You have no speedometer so the issue is somewhere between the cluster and the differential. If your other gauges are working, it's not as likely to be the cluster. I would start by replacing the VSS, it should be less than $30 then check all the wires back to the cluster.

JSchuricht is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome