launch at the track - Ford Powerstroke Diesel Forum
Drag Talk/Racing Lets see them slips, How To's, FAQs

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 02-04-2010, 08:29 AM Thread Starter
Compression Ignition Addict
 
04stroke's Avatar
 
Join Date: Jun 2008
Location: Ft.Lauderdale
Posts: 368
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
launch at the track

i went to the track lastnight for the first time.. first run i did 2 wheel drive 8psi boost launch and spun really bad n ran 16.04 at 87mph. ..so next run i did 4wheel 20 pound launch n spun all 4 n ran 15.6 at 85mph. what do you guys usually do for launchs not to spin? there was a truck there like mine stock lift tho ran 14.1

2004 F-250 5.9
97 12 valve P-pump tuned,4k and worked!
04stroke is offline  
post #2 of 4 Old 02-12-2010, 02:16 PM
Powerstroke.org Fanatic
 
MichaelP's Avatar
 
Join Date: Feb 2007
Location: Happy Valley, Oregon
Posts: 144
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I'll bet your traction bars are preventing wheelhop but not planting the rear tires very well. I've worked out suspension issues on a few vehicles, but never anything with that much lift.

Regards,
Michael Pliska

ISSPRO Engineering Manager

1995 F350 PSD CC DRW, 271k miles
10 ISSPRO Performax™ gauges, Tymar Intake, Gutted EBPV, Tymar 3x4" DP, Tymar 5" exhaust, Cat's lost, Baby Swamps, Swamps tuning, Tricumulator springs and Accumulator Valve, Tru-Cool 4590
1998 S&S 9.5' slide-in camper
33' enclosed tag trailer with 2 drag cars (73 Vega Super-Gas & 74 Vega ET)
92 GMC Typhoon, 73 Chevy Blazer with Pontiac 400, 73 T/A 455
GOA, IDPA & NRA member and certified firearms instructor
MichaelP is offline  
post #3 of 4 Old 02-12-2010, 03:14 PM Thread Starter
Compression Ignition Addict
 
04stroke's Avatar
 
Join Date: Jun 2008
Location: Ft.Lauderdale
Posts: 368
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
yeah i dont get any wheel hop in the back..my front tires jerk the wheel alot when i launch n i hear the tires spinning i actually have it on video.. but i was wonderin if mabye i put stock tires if it would hook better or not rip the wheel so bad?

2004 F-250 5.9
97 12 valve P-pump tuned,4k and worked!
04stroke is offline  
post #4 of 4 Old 02-13-2010, 09:49 PM
Compression Ignition Addict
 
Join Date: May 2007
Location: San Antonio TX
Posts: 310
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
try about 12-15psi. maybe the 6.0 is different with boost but thats what i do with my 7.3.....hooks up pretty good for the exeption that i dont have traction bars so i have real bad axle wrap. 40's with power sucks without bars, i already sheared a leaf spring bolt with my blocks

2000 PSD CC 4x4 Long bed
12 inches of lift with 40's on 20's.
250cc hybrid single shots
fuel system with no bowl and RR
h11 studs, rods, and 910 valve springs
4:56 gears front and rear
Phantom II gauges: EGT, Boost, Fuel, and Trans
BTS tranny and a 38r that cant keep up
Tuned by Truck Source Diesel

jmiller3104 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome