Starter/relay issue??? - Ford Powerstroke Diesel Forum

 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 03-30-2014, 06:03 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Mar 2014
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Exclamation Starter/relay issue???

When I went to start my truck the starter would start spinning but did not actuate out. It kept buzzing even with the key out of ignition, had to disconnect batteries. So I replaced the starter and still the same issue. Do I need to replace relay? If so where is it and how do I do it?
Dieselfartz is offline  
post #2 of 3 Old 03-30-2014, 06:34 AM
Compression Ignition Addict
 
Join Date: Dec 2007
Posts: 6,204
Thanks: 7
Thanked 233 Times in 224 Posts
Mentioned: 6 Post(s)
Quoted: 75 Post(s)
Feedback Score: 3 reviews
Well, they're Not all the same

You should Always post the yr/mdl/engine when asking for help....
NoRalPh is offline  
post #3 of 3 Old 03-30-2014, 06:48 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Mar 2014
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
It's. 2003 crew cab long bed 7.3
Dieselfartz is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome