6.0 Ran Hot - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 10-02-2013, 04:48 PM Thread Starter
Powerstroke.org Rookie
Join Date: Oct 2013
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
6.0 Ran Hot

I am new to the diesel scene but love my 2007 250 with the 6.0. I bought the truck with 150,000 miles on it and it now has 167,000. Due to not knowing the history of the truck I am not sure if any bullet proofing was done prior to my ownership. With this being said the truck ran hot a few weeks back after a two hour trip, I added some coolant to the truck and then it seemed fine for a few days and din;t notice any thing on the ground when I parked at home. Today I notice coolant on the ground where I park at work when I backed out of the space. When I got home I crawled under the truck and it looks as if there has been a leak for some time due to the staining on the heads where it meets the engine block. I know leaking coolant would be better from a hose but can any one tell me their thoughts on this scenerio and what I need to do to fix it? thanks
g8tor38 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome