7.3 shut down need help - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-27-2013, 04:39 AM
Powerstroke.org Rookie
 

Join Date: Jul 2013
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
7.3 shut down need help

I was heading down the road and engine just shut down, now engine will turn over but will not start. I can spray engine starter in breather and engine will fire and shut right back down. I have checked filter housing and the fuel is getting there so i'm thinking fuel pump is working. Any ideas what maybe wrong with this. Truck is a 1999 f350 7.3 thanks
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 07-27-2013, 04:55 AM
Compression Ignition Addict
 

Join Date: Jan 2007
Location: Santa Rosa, CA
Posts: 2,026
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
have you change the cam sensor? known problem w/ the 7.3's
check fuses
Reply With Quote Quick reply to this message
  #3  
Old 07-27-2013, 05:05 AM
ADMIN AND TECH


 

Join Date: Oct 2006
Location: winston salem north carolina
Posts: 9,208
Thanks: 0
Thanked 4 Times in 4 Posts
Feedback Score: 0 reviews
check oil level , possibly cam sensor , check all fuses , in all seriousness , really need to get it on a scanner and see what codes are in it and monitor data to see what it doesn't have that it needs , there is a list of things it could be , and the worst thing to do is start throwing parts at it , besides maybe a cam sensor
Reply With Quote Quick reply to this message
  #4  
Old 07-27-2013, 07:43 AM
Powerstroke.org Sponsor

 

Join Date: Apr 2010
Location: Defiance
Posts: 3,480
Thanks: 165
Thanked 38 Times in 38 Posts
Feedback Score: 1 reviews
For the love of our rides, can there please be a sticky on the main page or something for people to see links of engine damage from using starting fluid.

Don't ever use starting fluid. If you feel the need to use something similar then use WD40 or some other type of penetrating oil. Never ever ether.

Anyway check fuse #30 under the dash. I think that's the one for the IDM/fuel bowl heater.

Sent from AutoGuide.com Free App
Reply With Quote Quick reply to this message
  #5  
Old 07-27-2013, 08:00 AM
Powerstroke.org Rookie
 

Join Date: Jul 2013
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I have checked oil level and fuel pump, Hpop, and found nothing. I went out this morning truck fired up and ran for bout 1min. then just like the switch was turned off shut down and will not fire again.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 07:55 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors