Powerstroke 7.3 2001 mod garrett GTP38R upgrade having issues - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-10-2013, 05:26 PM
Powerstroke.org Rookie
 

Join Date: Aug 2012
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Powerstroke 7.3 2001 mod garrett GTP38R upgrade having issues

Hi all !

On the weekend I installed a new garrett GTP38R turbo and banks power elbow and 4" SS ( Diamond eye ) straight through system on my truck.

Its not running the best and seams to have a slight miss.
Its coming up with the following codes..

P0476- Exhaust pressure control valve perform
P0269- Cyl 3 Contribution/ balance fault
P0284- Cyl 8 Contribution/ balance fault
P1293- High Side open bank 1 ( Right )
P1294- High Side open bank 2 ( Left )

Anyone had troubles with mounting these elbow hitting the firewall ? ( I dont think its hitting but damm sounds like it .
Its making a loud drumming noise in the cab, little oil leaks also after install. looks like its coming out of the rod on the turbo pedestal. I left it pushed all the way in like the instructions said ?

Your help will be greatly appreciated !!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 07-10-2013, 06:28 PM
Premium Member
 

Join Date: Apr 2011
Location: Baton Rouge
Posts: 1,127
Thanks: 2
Thanked 3 Times in 3 Posts
Feedback Score: 1 reviews
If I were you I'd go over all your wire harnesses and make sure that's all straight and tight. Are you running stock tuning?
Reply With Quote Quick reply to this message
  #3  
Old 07-10-2013, 06:43 PM
Powerstroke.org Rookie
 

Join Date: Aug 2012
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Ok,

I'm running a DP tuner
Reply With Quote Quick reply to this message
  #4  
Old 07-10-2013, 09:57 PM
Powerstroke.org Rookie
 

Join Date: Aug 2012
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I cleared both high side open banks faults . They were stored while I cranked it without injector pulse to prime turbo with oil before starting . Seams to be mainly the exhaust pressure control valve perform issue
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 05:04 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors