White smoke, back firing - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 05-07-2013, 10:29 AM Thread Starter
Powerstroke.org Rookie
Join Date: Jan 2013
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
White smoke, back firing

I have a '99 F250 superduty with 7.3 and standard transmission.

The problem I am having is:
1. A lot of white smoke at start up and continues to come out, can't drive so smokey.
2. As truck is idling and smoking, if I give it just a little fuel it is backfiring. (Exhaust is cut and missing muffler, so exhaust ends just behind rear tire).
3. There is a coolant leak around water pump.
4. During idle, a loud tapping noise is heard from engine compartment.

These issues started after truck started surging (like cutting out at highway speed).

Someone please give me some suggestions.. Thank you.
john24dis is offline  
Sponsored Links

backfire, surging, white smoke

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome