hard starting 6.9 IDI - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-14-2013, 04:46 PM
Powerstroke.org Rookie
 

Join Date: Apr 2013
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Angry hard starting 6.9 IDI

Ok, new to the forum so any help would be greatly appreciated.

I just finished a bunch of work on an 86 F350 Dually 4x4. Including installation of a rebuilt ATS turbo from a 7.3 I picked up. I robbed the injectors and fuel filter base from that engine. with the injects I put in all new return lines and o rings, along with the new bronz washers for the injectors. Reason for injector switch was they appeared to be in much better shape.

I also installed a 3" downpipe and 4" stainless exhaust.

A ZF 5 speed was also part of the 2 week project.

Now the bad, it starts hard. Cranks easy, but takes a lot of that easy cranking to get it going. I get white/grayish smoke during cranking. When it does fire up I get a good puff of smoke, but then it clears up and runs like a dream.

Before the upgrades it started like a dream, glow plugs all seemed to work, and are new(bosch). Glow Plug light in the dash still comes on as it did before the build.

Aside from the starting problem the truck is working sweet with the upgrades.

Last edited by mikeym70; 04-15-2013 at 08:19 AM.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 04-28-2013, 04:27 AM
Compression Ignition Addict
 

Join Date: Jan 2011
Location: jamestown, nd
Posts: 406
Thanks: 0
Thanked 3 Times in 3 Posts
Feedback Score: 0 reviews
The injectors you installed have a higher cracking pressure a weak injection pump or one not designed for those
Pressures takes awhile to get the pressure needed to crack injectors properly. I have seen this in tractors several times new sticks and they start like crap


Sent from AutoGuide.com Free App
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Tags
idi, long crank, starting

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 11:47 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors