2000 xcursion miss firing but stops after another key cycle - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 03-03-2013, 07:55 AM Thread Starter
Powerstroke.org Rookie
Join Date: Mar 2013
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
2000 xcursion miss firing but stops after another key cycle

Ok so I took my excursion to the shop and had diagnostics done. They tell me it throwing 3 codes; one for the glow plug circuit, back pressure circuit and one for the #2 injector. when I drive it will be fine one minute and miss firing the next; when I pull over and do another key cycle it will run fine again and then start miss firing again.
I have heard that the clips for the injectors and wear out and cause the injector to be loose. My question for any one who can answer. Will a loose injector cause the truck to throw a glow plug circuit code and a back pressure circuit code? The mechanic wants to replace my ecu and I don't want to pay 1600 bucks in labor and parts for a loose injector.
7.3sandtree's is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome