'99 7.3 Noob with issues - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 02-22-2013, 04:31 PM Thread Starter
Powerstroke.org Rookie
Join Date: Feb 2013
Posts: 9
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
'99 7.3 Noob with issues

Hi guys,

My '99 F250 7.3 is giving me troubles.

About 2 weeks ago I took it into the shop to have the rear end looked at (whining noise on acceleration - pinion bearing and new yoke) - they repaired and also did an oil change. Truck ran fine from when I picked it up (could hear myself think with the new bearing/yoke thank god).

Picked it up Monday morning - then on Friday morning - started it up (-20C here) and let it idle for about 1 minutes.

When I hopped in to head to work - check engine light was on. Started to drive away and truck shook violently and had no power.

Turned around and parked it. It starts pretty rough but once started idles ok with a minor touch of rough.

I read overfilling oil could cause an issue so I checked that out and it was for sure a good ways about MAX line - so I dropped some oil to get it into the operating area - that didnt cure anything.

Its got a brand new fuel filter in it.

The check engine light comes on when I accelerate and if I let off the pedal, it goes out, accelerate on, let off goes out etc.. Have an ODBII reader - but wont pull up ANY codes.

Sounds like a wiring harness?

Appreciate any advice.
westy1717 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome