powerloss after egr delete - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-18-2012, 09:30 PM
Powerstroke.org Rookie
 

Join Date: Sep 2012
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
powerloss after egr delete

Hey guys,
I did an EGR delete a while back and ever since I have an extreme loss in power. I have checked all of the tubes. The down pipe, all exhaust connections and injector connections. I have since replaced the FICM because it was throwing codes. During that time I replaced the glow plugs as well. One glow plug was faulty and since it wasn't that big of a deal I changed all of them. I have gone over everything I have read on this forum still cannot find the source of the problem. Also when I did the EGR delete I took apart the turbo and cleaned it. Is it possible to put the veins back in-in the wrong order?

Thank you for any help.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 10-02-2012, 04:49 AM
Powerstroke.org Rookie
 

Join Date: Oct 2012
Location: Tri-Cities, WA
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Did you......

possibly forget to reconnect the turbo actuator pigtail? just asking...had to be asked.
Could you have not gotten all the veins and the ring installed correctly when you did the turbo clean? It sounds to me like you have NO turbo action happening. How about the air line connection from the boost sensor? This hose is on the passenger side of the intake and you would have had it disconnected during the operation of deleting. Is the hose in one piece, no cracks, etc?

John
Reply With Quote Quick reply to this message
  #3  
Old 10-02-2012, 04:52 AM
Compression Ignition Addict
 

Join Date: Dec 2008
Location: Naples, Florida
Posts: 384
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
Are you getting any trouble codes?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Tags
powerloss, turbo 6.0, vgt assembly

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 05:34 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors