need help with 7.3 fuel system problem... lacks power - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-29-2012, 09:57 AM
Powerstroke.org Rookie
 

Join Date: Jul 2012
Location: Reading PA
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Cool need help with 7.3 fuel system problem... lacks power

Hello-

I recently bought an 1995 E350 Econoline van, it has a 7.3 DI turbo... It ran well enough to get it home but it is now lacking power, makes it hard to get up hills. It's not just a little, but really lacking power, like it has a very hard time moving out from a start. It starts up and idles fine, just no power... I am going to do a fuel pressure check and also the MAP sensor check (anyone know where that is located in a van?), check the screen at the top of the HPOP, etc... and maybe a new fuel filter wouldn't hurt. I should also mention that the day I brought it home my wife was following behind me and she saw a bit of black smoke when I was going uphill. It also had a minor bit of a fuel drip from somewhere under the engine but that was minimal, dripped for a few hours after the long drive then it stopped. any suggestions are greatly appreciated.

Last edited by 68dutchguy; 08-02-2012 at 03:44 AM.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Tags
lacks power fuel problem

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 08:46 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors