96 F350 7.3L No power above half throttle - Ford Powerstroke Diesel Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 07-26-2012, 09:03 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Feb 2012
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Angry 96 F350 7.3L No power above half throttle

This is pathetic. I'm in the middle of a cross-country run pulling a 12,000 lb 5th wheel. Early in the trip I switched to the rear tank and lost power so I switched back to the front tank and full power returned in a few minutes. The next day I lost a cylinder so I put in in Indianapolis and turned the trouble over to "Turbo & Diesel Injection" who put a full set of injectors. The truck ran great until it blew an exhaust manifold gasket in Oklahoma. I put in in Amarillo, TX and went to the most highly recommended Ford diesel shop in town. He pulled the engine because the bolts had to be drilled out and tapped. He alse put in a new radiator, water pump and thermostat.

I picked the truck up at the end of the day and it drove terrific. Being behind schedule, I hitched up the trailer and took off that night. All seemed fine until I40 began to climb heading into New Mexico. That's when I realized that there was no increase in power above half throttle. I've limped all the way to Flagstaf, AZ with a top speed of 50mph on the flat and chugging up hills in 2nd gear at 2500rpm. I drained the fuel bowl and replaced the fuel filter but there was no change.

I still need to climb over the Sierras. What did they do to my truck?

Last edited by mnorth57; 07-26-2012 at 10:02 PM. Reason: I forgot something
mnorth57 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 03-10-2013, 10:08 PM
Powerstroke.org Rookie
 
Join Date: Mar 2013
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
have you figured out what it was. my truck has not increase in power over half throttle. its like the turbo is not spooling at all
stolennitrous is offline  
post #3 of 4 Old 03-10-2013, 10:24 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Feb 2012
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Not much better...

I've replaced the injectors, fuel pump and exhaust manifolds. I have plenty of power and torque coming off idle but there's no additional power available in the second half of the throttle travel.

You don't really notice it when driving empty but the truck will barely pull an 8000 lb 5th wheel up a hill.
mnorth57 is offline  
post #4 of 4 Old 03-16-2013, 02:29 AM
Powerstroke.org Rookie
 
Join Date: Mar 2013
Posts: 18
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Have you had your fuel injector control module checked. Some of you performance issues fall into the category covered by this module. There is a video on this site that describes the symptoms and test procedures.
prheitz is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome