05 F250 Super Duty 6.0 PowerStroke Diesel - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-26-2012, 06:31 PM
Powerstroke.org Rookie
 

Join Date: Jun 2012
Posts: 24
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Smile 05 F250 Super Duty 6.0 PowerStroke Diesel

Recently purchased my first diesel truck, used with 99k, and with the standard 30 day or 1000 mile 50/50 warranty, was fine for the test drive but after I took it home the second tome I drove it for 120 miles the turbo blew a hole in one of the larger tubes and was making an awful whistling noise. Dealer took it in and fixed it all and didn't even charge me the 50 percent that they clearly could have. Well I got it back and immediately put it to a road test with some distance.

Thus far it hasn't failed me after almost 2k miles in three days. Except the check engine wrench lit up and now the ABS light as well. The brakes seem to be fine but maybe I have no ABS effect now. Second while in cruise out of no where about two or three times a drive it will just shut off the cruise, speedo drops to zero, then it just goes right back to normal and I hit resume on the cruise and all is good again. Third and last issue,the Turbo was not replaced as I thought it recently had been but instead taken apart and cleaned good they said it didn't need replaced. Now it has a slight up and down surge in the boost and engine rpm's at mild to medium acceleration,but if hammered to speed its not to noticeable. Thinking the Turbo needs replaced and was talking with someone else who mentioned something about a harness know to be bad on these trucks.

Thanks for taking the time to read my post and please just let me know if you have any experience with these issues as I have not been able to locate anything specific to my issue.

Last edited by PowerStroker72; 12-30-2012 at 06:53 PM. Reason: had no replies yet and noticed a misspelled word
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 12-30-2012, 06:37 PM
Powerstroke.org Rookie
 

Join Date: Jun 2012
Posts: 24
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Bump, no one with any similar issues? Now have a miss that comes and goes as well and its not the oil or fuel filters as that's all been changed in the last 3 days, the oil twice within a week. Until diagnostics can be run to check readings I don't know if its an injector but I personally don't think so at this point. When I start it in the morning the miss is there, but within a minute or two its gone, then it starts again within a few to several minutes of that and now this evening it started the crud where it just cuts out like its going to die. So I shut it off went into the store, come back out 5 minutes later and it starts right up and doesn't do that again the rest of the way home but did have the miss. Could really use some educated input here as I'm wondering if there is a weird electrical issue going on???

Also just some fyi, this truck has now 153k on it and a new ficm, hpop, ipr valve, and orings on the injectors and standpipe I think he said. Was done at antrim diesel at 123k or so. Thanks

Last edited by PowerStroker72; 12-30-2012 at 06:58 PM.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 11:35 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors