7.3L Power Loss after Warm. - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 02-15-2012, 05:01 PM Thread Starter
Powerstroke.org Rookie
Join Date: Feb 2012
Posts: 9
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Question 7.3L Power Loss after Warm.

I got a stock 7.3 (as for as I know) in a 2002 F-250. I had a problem where it would die and not start back up for awhile. Had the local Ford dealer look at it. They ended up replacing the computer. Now, after driving it for 40 miles straight the engine will lose all power. The lights on the dash come onand the truck will not go. The engine is still running. I remove my foot from the fuel pedal and wait a few seconds and the truck goes back to running fine. The fequency at which this happens changes. In fact, there is an off ramp I take on my way home that has a speed bump. Everytime, I hit that speed bump the truck turns off completely. However, does not do it with bumps in the road. Does anyone have any ideas? I have spent $3000.00 at the local dealership and I am still having this problem. Looking for someone who has a clue since this dealership does not.

I know I am new here but can someone help please.

Last edited by BOS811; 02-16-2012 at 03:57 PM. Reason: No response
BOS811 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome