95 f250 7.3 injector might be bad - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 12-22-2011, 05:35 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Dec 2011
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
95 f250 7.3 injector might be bad

i thing my injector might be bad when i start the truck up in the morning and take off when i hit 40mph the engine will start to shake and when you step on the gas it go away when the truck warm up it dors not do it but the rmp well move a little bit
tony4mitchell is offline  
post #2 of 4 Old 12-22-2011, 05:41 PM
Compression Ignition Addict
 
jesilvas's Avatar
 
Join Date: Feb 2009
Location: Nacogdoches, TX
Posts: 11,148
Thanks: 0
Thanked 27 Times in 25 Posts
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Feedback Score: 0 reviews
That's a big thing to start at. Could be a loose UVCH making intermittent connection making it seem as though it's missing. U joint. Trans. Diff. Drive shaft. Could be the EBPV closing when cold like it should. You could unplug it from the base of the pedestal and see if it stops.



2000 F-350 Lariat Super Duty, Dually, CCLB, 7.3L
4R100, 2wd
330,000 + miles
jesilvas is offline  
post #3 of 4 Old 12-22-2011, 05:49 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Dec 2011
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
ok when it idle the rpm move and the steering wheel shake a little took it to ford and they said to replace the idm so i did and still the same took it back they still said i had all 8 injector were no good that hard to believe after one day they all go bad
tony4mitchell is offline  
post #4 of 4 Old 12-23-2011, 02:49 PM
Compression Ignition Addict
 
jesilvas's Avatar
 
Join Date: Feb 2009
Location: Nacogdoches, TX
Posts: 11,148
Thanks: 0
Thanked 27 Times in 25 Posts
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Feedback Score: 0 reviews
It sounds like they have no idea what they're talking about.
The RPMs move and wheel shakes. Vague.
Does it have any codes? You said it's only when cold?
I'd check the UVCHs first.



2000 F-350 Lariat Super Duty, Dually, CCLB, 7.3L
4R100, 2wd
330,000 + miles
jesilvas is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome