6.0l hard to start, blows white, then dies - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 3 Old 11-28-2011, 07:57 AM Thread Starter
Powerstroke.org Rookie
Join Date: Jul 2008
Posts: 24
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to xceslimitd Send a message via Yahoo to xceslimitd
6.0l hard to start, blows white, then dies

The problems with this truck seem to be endless. The truck as about 145k on it and here here is a list of mods and repairs:
Mods: 4" dp, 5" back, S&B intake, EGR delete, SCT X3 (presently tuned to stock)
Repairs: FICM and CAC about 3 years ago, entire cooling system 2 years ago, new VGT solenoid, oil supply and drain tubes, new ICP and EPS, 2 new batteries, 1 injector twice, head studs and gaskets (all down within the last 45k miles as I got the truck with 100k on it).

I had replaced the injector a few months ago and the truck was running fine for about 2 months. About a month ago on my way home I stopped and let idle while I ran a quick errand (less than 2 or 3 minutes). When I came back out the truck coughing and clanking and blowing white and black smoke. I was about 3 miles from home so I headed that way and she died. I scanned her, got a Cyl 2 fault, cleared codes and tried to start to starter her. She ran for a few seconds and died. We towed her back to the house the next day. We tried to start her again and it sounded as if she were hydro-locked. I scanned codes again and got one for the EPS so I replaced it. Didn't fix problem. Ran an injector buzz test which passed. Replaced Cyl 2 injector with warrantied part because of first scan. She'll start but with several seconds of cranking. She'll blow white smoke, run OK for a few min, then get loud and die out. If I put her in drive she'll die immediately. She won't run long enough to throw any codes. I'm thinking fuel delivery but have no idea. Any thoughts?

04 F-350 6.0L Lariat CCSB FX4
Custom DRW Conversion
S&B Cold Air intake, ZooDad, 4" Down Pipe, 5" back, SniperTuner, Trans/EGT/PSI A pillar gauges, AirBags, 4.10 Gears w/ Factory LS in rear and TruTrac in front, B&M Trans Pan, Pioneer AVIC-D3 (Bluetooth & back-up camera) w/ Kenwood speakers & 8" Rockford in custom box, Cobra 29LTD Classic CB, 70g in bed fuel tank

Last edited by xceslimitd; 11-28-2011 at 08:03 AM.
xceslimitd is offline  
Sponsored Links
post #2 of 3 Old 01-03-2012, 04:39 PM
Powerstroke.org Rookie
Join Date: Jan 2012
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
check the coolant reservoir for diesel. could be a leaky jacket or sleeve. take a sample of your coolant and let settle for a day or so, orange haze/film or glob on top is diesel.
ranger351 is offline  
post #3 of 3 Old 01-06-2012, 11:01 PM
Premium Member
master1973's Avatar
Join Date: Jan 2012
Posts: 33
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I would think EGR cooler, But you have a delete, maybe head gasket I think, getting any air bubbles in overflow bottle wile running?
master1973 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome