08 6.4 No throttle w/engine light - Ford Powerstroke Diesel Forum
LinkBack Thread Tools Display Modes
post #1 of 2 Old 11-22-2011, 12:56 PM Thread Starter
Powerstroke.org Rookie
Join Date: Nov 2011
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
08 6.4 No throttle w/engine light

I have an 08 Superduty with 6.4Powerstroke. Today it decided to start flashing the engine light. This was accompanied by the throttle "going away". It makes a slight thump noise and all power is gone. It idles just fine but no throttle. Any suggestions? Dealer in town isn't very good at getting trucks out of shop and not willing to wait months for my truck back....
cookie2 is offline  
post #2 of 2 Old 11-22-2011, 01:34 PM
Compression Ignition Addict
Join Date: Sep 2011
Posts: 4,368
Thanks: 6
Thanked 138 Times in 131 Posts
Mentioned: 3 Post(s)
Quoted: 48 Post(s)
Feedback Score: 2 reviews
first order of business is pull the diagnostic trouble codes
drunk on diesel is offline  

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome