Truck stalls while driving - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 7 Old 11-12-2011, 05:30 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Nov 2011
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Unhappy Truck stalls while driving

First let me say glad to be here as a new member.
Now the issue. My 99 f250 started running rough, especially at idle (No codes stored). Here is what I did first: Oil and filter change, replaced CPS, Verified HPOP was filled, Ohmed idle verification micro switch. It continued to get worse and finally progressed to stalling at idle. It would restart quickly with a bit of white smoke. Bit the bullet and took it to ford. They said that the injector electrical test was ok, that #8 injector was bad and #1 was borderline on the contribution test, and that the ICP was ok. (unplugging ICP didnt change problem) I just replaced all of the injectors with stock remans, also the valve cover gaskets with new harness, and installed motorcraft glow plugs. Got it started today and for the for a while it ran really good, although it seemed to have a slight lope in the idle. After putting some more miles on it (25 or so) it started having trouble coming back to idle after letting up on the accelerator. Also the rough idle started again, and it took a few extra cranks to start, Check engine light came on briefly and went out. Now it started stalling while driving, even while accelerating. Still no stored codes and no check engine light! I am at the end of my knowledge on this problem and need a hand!
Superblue99 is offline  
post #2 of 7 Old 11-12-2011, 05:52 PM
Shade tree mechanic


 
95dieselsmoke's Avatar
 
Join Date: Mar 2008
Location: Lake Tapps, Wa.
Posts: 8,298
Thanks: 2
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 1 reviews
After an injector swap it can take up to 100 miles to work all of the air out of the system and for it to run correctly without any sputter. How did the old VC gaskets and harnesses look? Any burned end on any of the plugs? I didnt hear any mention of a fuel filter change... did you check to see if it was up to par?

MATT

Now featuring a 6.4 fat bottum 6 speed
95 f250--238k and counting
RDS stage I's-TW live tuned-Dana 60 swap-9" lift/40x13.5x20 ProComps-ZF5 swap/short throw/South Bend CON OFE-Iron Bull front-AFE CAI-SD innercooler-Fab Tech traction bars-MBRP DP/6" black miters-Autometer boost/pyro

"If you dont have ambition and big dreams, you end up working hard for someone who does"
95dieselsmoke is offline  
post #3 of 7 Old 11-12-2011, 07:08 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Nov 2011
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Wiring looked good, replaced them because I heard that they tend to go bad. Figured on only going under the valve covers once and doing it all at once. Forgot to list the fuel filter, yes it did replace it in the early troubleshooting.
thanks
Superblue99 is offline  
post #4 of 7 Old 11-12-2011, 07:20 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Nov 2011
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
My new short list of things to try is just based on what I have read and what makes sense to me. I would love some feed back. Here is the list.
1. Put original CPS back in.
2. Check IPR coil ohms, consider replacing IPR.
3. Check inlet screen on FPR.
4. Troubleshoot fuel system front to back. Lines plugged, bad fuel pump, etc.
5. Swap out IDM relay

The stalling while driving has made it dangerous and totally undriveable. Since that is a new symptom, I am wondering if there has been more than one problem all along.
Superblue99 is offline  
post #5 of 7 Old 11-12-2011, 07:48 PM
Powerstroke.org Rookie
 
Join Date: Jul 2011
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
You may want to pay the 99 bucks for powerstrokehelp.com if he doesn't have the answer then get out the road flare and the gasoline!
nycfyrman is offline  
post #6 of 7 Old 11-12-2011, 07:54 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Nov 2011
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Yeah no kidding. Trouble is there are no real diesel techs anywhere close to me. I am starting to think I may know more about my engine than the local ford techs, most of them a gasoline engine mechanics that have gone to a few Ford schools. I already put in the injectors based on their troubleshooting, hope it was not all for nothing.
Superblue99 is offline  
post #7 of 7 Old 01-04-2012, 01:24 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Nov 2011
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Seems that the cam sensor I swapped was bad, changed it out with a OEM sensor. that solved the stalling. It started running rough again and this time when I unplugged the Injection Pressure sensor to test it the idle smoothed out proving that the sensor was bad. The sensor had previously been tested by Ford, but after the swap the truck ran perfect. Also performed the HPOP oil change that is shown on powerstrokehelp.com and plan to continue this practice to extend injector life. Long story short, I think I changed injectors due to Ford advice, when I could have been replacing the ICP sensor. Also note to self: Only use Ford Cam sensors!
Superblue99 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome