egr codes no turbo on take off - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 10-03-2011, 01:54 PM Thread Starter Rookie
Join Date: Oct 2011
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
egr codes no turbo on take off

just wanted to post a quick note. I have a 08 f250 6.4 i was throwing a egr dtc and was in limp mode. i took off the plastic sensor cover on the egr valve and found that the pins that connect the sensor to the electric motor that activates the egr valve had corrosion like a battery terminal in one of the holes in the housing....with this said i was not getting the voltage to let the valve operate when the computer wanted it to...running strong after a 5 min cleaning
ffnate61 is offline  
Sponsored Links

egr valve

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome