2003 7.3 Cuts out now and then - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-04-2011, 06:30 PM
Premium Member
 

Join Date: Sep 2011
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Unhappy 2003 7.3 Cuts out now and then

Hi Guys. My 7.3 just cuts out now and then some times weeks and Ks apart. Switch off and on and it starts. The problems getting worse lately being twice yesterday. Any ideas?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 09-05-2011, 03:44 AM
Compression Ignition Addict
 

Join Date: Dec 2007
Posts: 2,859
Thanks: 6
Thanked 1 Time in 1 Post
Feedback Score: 2 reviews
try a new cps
Reply With Quote Quick reply to this message
  #3  
Old 09-05-2011, 04:17 AM
Compression Ignition Addict
 

Join Date: Aug 2007
Location: New Brunswick, Canada
Posts: 774
Thanks: 1
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
There has been recalls for CPS.
I had the same problem with my 6.0L and they told me they had a silent recall on the same problem.
My neighbour with a 7.3 has been recalled for his.
Reply With Quote Quick reply to this message
  #4  
Old 09-05-2011, 04:57 AM
Real Men of Genius
 

Join Date: Apr 2010
Posts: 5,126
Thanks: 1
Thanked 17 Times in 16 Posts
Feedback Score: 8 reviews
Yeah, always always always try the cheapest thing first! Haha! The dealership will most likely tell you it's a fuel injector (normally the #8 or the #3 injector) that died, but it may very well be (and probably is) the CPS - Crankshaft Positioning Sensor.
Reply With Quote Quick reply to this message
  #5  
Old 03-15-2012, 09:38 PM
Powerstroke.org Rookie
 

Join Date: Feb 2010
Location: Alberta, Canada, Out in the sticks on a small farm.
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
+1 more vote for Cam Position Sensor!
My 02 F250 with the 7.3 did the exact same thing, replaced it andits been working perfect the last 8 years!
Pick one up at an International truck parts center...they were cheap there, and it gave me better mpg too. Mind you it could be a coincidence...
Reply With Quote Quick reply to this message
  #6  
Old 04-01-2012, 07:59 PM
Powerstroke.org Rookie
 

Join Date: Apr 2012
Location: Black Forest, Colorado
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Hi, new guy here. just replaced CPS, second one 257000 miles and now it runs like a gasoline with 2 or 3 bad plugs. Any ideas??
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 11:54 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors