4x4 switch not working - Ford Powerstroke Diesel Forum
LinkBack Thread Tools Display Modes
post #1 of 2 Old 07-10-2011, 08:05 PM Thread Starter
Powerstroke.org Rookie
Join Date: Jul 2011
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
4x4 switch not working

I have an '04 f250 and my 4H and 4L switch lights up on the dash cluster but in all reality the 4 wheel drive did not kick in. What is the problem and what is the solution?
Thanks for all input. Much appreciated.
PowerstrokerFl is offline  
post #2 of 2 Old 07-10-2011, 08:22 PM
Serving Our Country!
zgerm01's Avatar
Join Date: Feb 2007
Location: Morehead City, NC
Posts: 178
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
See if this helps

2003 F-250 Crew Cab 6.0
Edge Insight CS, SCT XCal2 tuned by IDP, FCDP EGR delete kit w/ up-pipe, 4" MBRP Turbo-back exhaust, cat-delete, 6" Suspension Lift w/ 37" Toyo M/T's on BMF Novocane 20x10's, zoodad Mod. More to come...
zgerm01 is offline  

4x4 , electric , electrical , lifted trucks , off road

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome