7.3 died - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-08-2011, 05:41 AM
Member
 

Join Date: Mar 2011
Location: arnold, mo
Posts: 41
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
7.3 died

i have a 97' 7.3. A few days ago about 1/2 mile from the house it just died after a right turn. Since I was coasting down hill I slipped it into neutral & cranked it-no start. Turned onto side road, cranked-no start. 5 minutes later it fired up & has been fine since. The suddenness of it's dying reminded me of when the cam speed sensor went out. that sensor was replaced 3 times under warranty. Then on 2 different occasions ford just replaced it under some recall when it was in the shop for something else. any ideas on where to start. i'm due to be in some remote areas & of course it will happen on a logging road in the middle of clark national forest next time. there's hardly any cell phone reception there either.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 07-08-2011, 06:03 AM
Powerstroke.org Rookie
 

Join Date: Jul 2011
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
sorry, cam sensor was my first thought
Reply With Quote Quick reply to this message
  #3  
Old 07-08-2011, 06:40 AM
Member
 

Join Date: Mar 2011
Location: arnold, mo
Posts: 41
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
sensor was my 1st thought too. supposedly the sensor has been upgraded. makes me wonder why ford replaced it 2 more times when i had in the shop for other issues.
1st major repair was shorted out valve cover gasket that fried the injector computer, 4 injectors, & partial wiring harness. 2nd major issue, the fuel lift pump went out.
Reply With Quote Quick reply to this message
  #4  
Old 07-08-2011, 09:33 AM
Powerstroke.org Rookie
 

Join Date: Jul 2011
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
what were the symptoms of the fuel lift pump failure? have you been told that once injectors start going that you can expect all off them to fail soon?
Reply With Quote Quick reply to this message
  #5  
Old 07-08-2011, 03:15 PM
Member
 

Join Date: Mar 2011
Location: arnold, mo
Posts: 41
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
when the lift pump went it was leaking fuel. the injectors that failed got fried when the valve cover/wiring harness shorted out at 74K. so the failures were premature. the truck now has 103K. at what point do they normally start failing??
i did luck out recently on s valve cover gasket set with the wiring harnesses. a local towing company/repair shop had just installed this new gasket set on one of their trucks. i week later the engine blew. i happened to be in their shop getting a state safety inspection at the time. since they'd installed the gaskets they could not return them. they sold me the whole pkg for $40.00!!
Reply With Quote Quick reply to this message
  #6  
Old 09-29-2011, 06:11 PM
Powerstroke.org Rookie
 

Join Date: Aug 2009
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
This happened to me - check your engine oil level. If its low and you made a turn. You have a low oil sensor and if it senses low oil it will shut down the engine.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 05:29 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors