new injectors, then it ran now it wont - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 2 Old 05-21-2011, 07:50 AM Thread Starter Rookie
Join Date: May 2011
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
6.0 new injectors, then it ran now it wont

I had a bad injector in #7 and 3 so i replaced them all like a dummy. I had to use one of the old ones due to a bad one out of the box. The truck was running good then yesterday it lost power at idle and had the pedal to the floor, after it started going then it was fine drove about 15 miles then stopped. When it started back up ok then put it in gear and it died not to start again. On the old injector I had not replaced the seals so I just did that but still can not get it to start. any Ideas Please help!

Last edited by cmillekb; 05-21-2011 at 08:21 AM. Reason: add more info
cmillekb is offline  
Sponsored Links
post #2 of 2 Old 05-23-2011, 06:39 PM
Premium Member
Errick NDA's Avatar
Join Date: Jul 2009
Location: Welcome,N.C
Posts: 409
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 17 Post(s)
Thanks: 6
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Have you checked to see if you had good ICP pressure ????

Errick NDA is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome