99f250 diesel 7.3 engine light came on,rough idle - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 04-15-2011, 08:07 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Oct 2010
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
99f250 diesel 7.3 engine light came on,rough idle

(Just a lady, dont know nothing about my diesel. Anyone? Please help.) Ran the truck about 30 miles, ran beautiful. Parked it for 2 hours. Got in it. Engine light came on. In drive, with pedal to floor, only goes to 10rpm's. It was a very rough idle. I let it idle in park as it spit and sputtered. All of a sudden it idled up to 10rpms, dropped down to its regular idle, engine light went off and started sounding good. I hit the gas pedal and got good,regular power. Then all of a sudden it started getting choppy again and the engine light popped on. With truck off, I opened up the fuel drain valve and got some fuel out. Doesnt appear to seperate or have water in it. Does anyone know what it might be?
dreamer77 is offline  
post #2 of 3 Old 04-16-2011, 02:37 PM
Powerstroke.org Rookie
 
Join Date: Jan 2010
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Quote:
Originally Posted by dreamer77 View Post
(Just a lady, dont know nothing about my diesel. Anyone? Please help.) Ran the truck about 30 miles, ran beautiful. Parked it for 2 hours. Got in it. Engine light came on. In drive, with pedal to floor, only goes to 10rpm's. It was a very rough idle. I let it idle in park as it spit and sputtered. All of a sudden it idled up to 10rpms, dropped down to its regular idle, engine light went off and started sounding good. I hit the gas pedal and got good,regular power. Then all of a sudden it started getting choppy again and the engine light popped on. With truck off, I opened up the fuel drain valve and got some fuel out. Doesnt appear to seperate or have water in it. Does anyone know what it might be?
get a scan tool and check what codes your getting, could be something simple.
polish pete is offline  
post #3 of 3 Old 04-16-2011, 02:40 PM
Compression Ignition Addict
 
STRKTHS73's Avatar
 
Join Date: Nov 2008
Location: old saybrook, connecticut
Posts: 446
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Send a message via AIM to STRKTHS73
sounds like a crank shaft sensor

06 F-350
4" turbo back silverline exhaust
KMC XD series spy wheels
35" toyo m/ts, 5% window tints
4.5 rough country lift
triple pillar egt, boost, and trans temp
edge cts insight
CAT coolant swap at 30k
Sinister Coolant Filter
SCT X3 with custom tunes by vivian at QT
STRKTHS73 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome