Batteries not charging - Ford Powerstroke Diesel Forum

Camping/RV's Discuss camping, RV equipment and locations.

 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 06-27-2013, 01:34 PM Thread Starter
Compression Ignition Addict
 
new2deisel's Avatar
 
Join Date: Nov 2006
Location: SoCal
Posts: 680
Thanks: 2
Thanked 2 Times in 1 Post
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Batteries not charging

Just got back from vacation and figured I'd ask for some suggestions before I start looking myself. I went to start loading up yesterday to come home and noticed my generator wouldn't charge my batteries. My inverter started beeping in the middle of the night to let me know my batteries were low so I had to shut it off. In the morning I was able to turn the generator on but it didn't show it was charging so I couldn't lift my back beds up or lift the landing jacks to put trailer on truck. I had to use jumper cables from truck to trailer so I could get enough power to get everything situated to come home. I'm going to plug into shore power to see if it will charge that way. I'm thinking its my converter but haven't looked yet.
new2deisel is offline  
post #2 of 5 Old 06-27-2013, 03:21 PM
Compression Ignition Addict
 
jesilvas's Avatar
 
Join Date: Feb 2009
Location: Nacogdoches, TX
Posts: 11,148
Thanks: 0
Thanked 27 Times in 25 Posts
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Feedback Score: 0 reviews
Might be converter or an issue with the transfer switch.



2000 F-350 Lariat Super Duty, Dually, CCLB, 7.3L
4R100, 2wd
330,000 + miles
jesilvas is offline  
post #3 of 5 Old 06-27-2013, 03:25 PM Thread Starter
Compression Ignition Addict
 
new2deisel's Avatar
 
Join Date: Nov 2006
Location: SoCal
Posts: 680
Thanks: 2
Thanked 2 Times in 1 Post
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Quote:
Originally Posted by jesilvas View Post
Might be converter or an issue with the transfer switch.
Transfer switch is manual, figured it would be converter.
new2deisel is offline  
post #4 of 5 Old 06-27-2013, 03:37 PM
Compression Ignition Addict
 
jesilvas's Avatar
 
Join Date: Feb 2009
Location: Nacogdoches, TX
Posts: 11,148
Thanks: 0
Thanked 27 Times in 25 Posts
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Feedback Score: 0 reviews
In that case, usually yes.



2000 F-350 Lariat Super Duty, Dually, CCLB, 7.3L
4R100, 2wd
330,000 + miles
jesilvas is offline  
post #5 of 5 Old 06-29-2013, 08:42 PM Thread Starter
Compression Ignition Addict
 
new2deisel's Avatar
 
Join Date: Nov 2006
Location: SoCal
Posts: 680
Thanks: 2
Thanked 2 Times in 1 Post
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Got it figured out. Turns out I had some corrosion on my transfer switch plug.
new2deisel is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome