Batteries not charging - Ford Powerstroke Diesel Forum
Camping/RV's Discuss camping, RV equipment and locations.

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-27-2013, 01:34 PM
Compression Ignition Addict
 

Join Date: Nov 2006
Location: SoCal
Posts: 676
Thanks: 2
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Batteries not charging

Just got back from vacation and figured I'd ask for some suggestions before I start looking myself. I went to start loading up yesterday to come home and noticed my generator wouldn't charge my batteries. My inverter started beeping in the middle of the night to let me know my batteries were low so I had to shut it off. In the morning I was able to turn the generator on but it didn't show it was charging so I couldn't lift my back beds up or lift the landing jacks to put trailer on truck. I had to use jumper cables from truck to trailer so I could get enough power to get everything situated to come home. I'm going to plug into shore power to see if it will charge that way. I'm thinking its my converter but haven't looked yet.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 06-27-2013, 03:21 PM
Compression Ignition Addict
 

Join Date: Feb 2009
Location: Nacogdoches, TX
Posts: 11,008
Thanks: 0
Thanked 9 Times in 9 Posts
Feedback Score: 0 reviews
Might be converter or an issue with the transfer switch.
Reply With Quote Quick reply to this message
  #3  
Old 06-27-2013, 03:25 PM
Compression Ignition Addict
 

Join Date: Nov 2006
Location: SoCal
Posts: 676
Thanks: 2
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by jesilvas View Post
Might be converter or an issue with the transfer switch.
Transfer switch is manual, figured it would be converter.
Reply With Quote Quick reply to this message
  #4  
Old 06-27-2013, 03:37 PM
Compression Ignition Addict
 

Join Date: Feb 2009
Location: Nacogdoches, TX
Posts: 11,008
Thanks: 0
Thanked 9 Times in 9 Posts
Feedback Score: 0 reviews
In that case, usually yes.
Reply With Quote Quick reply to this message
  #5  
Old 06-29-2013, 08:42 PM
Compression Ignition Addict
 

Join Date: Nov 2006
Location: SoCal
Posts: 676
Thanks: 2
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Got it figured out. Turns out I had some corrosion on my transfer switch plug.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 10:51 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors