Signal Light Issue - Ford Powerstroke Diesel Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 6 Old 03-24-2014, 10:13 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Mar 2014
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Signal Light Issue

Hello fellow powerstroker's,

I was hoping someone could shed some light on an issue I'm having with my truck.

2002 Ford F350 SuperDuty 4x4
7.3L Diesel
380,000KM

The issue I am having is that my signal lights are only functioning when the headlamps are on. There are no signal lamps when the parking lights are on or with all lights off (daytime mode). The hazzards work in all conditions and the brake lights work in all conditions as well.

Do you guys think my multifunction switch has gone bad?
Spacerz is offline  
post #2 of 6 Old 03-24-2014, 02:43 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Mar 2014
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Update: I have no signal lights at all now. Even with the headlamp switched to the on position.
Spacerz is offline  
post #3 of 6 Old 03-25-2014, 08:44 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Mar 2014
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Update 2: I replaced the multifunction switch and am still having the same issue. When I turn the flasher on I get the arrow on the dash to light up once and then it shuts off completely. Does this sound like a relay issue?
Spacerz is offline  
post #4 of 6 Old 03-25-2014, 09:33 AM
Super Moderator

 
Heavy_GD's Avatar
 
Join Date: Aug 2013
Location: 804Va
Posts: 12,044
Mentioned: 66 Post(s)
Tagged: 1 Thread(s)
Quoted: 867 Post(s)
Thanks: 3,523
Thanked 832 Times in 777 Posts
Feedback Score: 3 reviews
my best guess is that the relay is faulty or being over loaded.

GD - 06 CCSB FX4 Lariat
Quote:
Originally Posted by G8orFord View Post
My magic wand broke a few years back when my crystal ball fell on it. Ruined the ball too. So we're going to have to figure this one out another way. YOU NEED A MONITOR or at least a good scanner.
Heavy_GD is offline  
post #5 of 6 Old 03-25-2014, 12:40 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Mar 2014
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Update 3: Replaced the relay with a brand new one. I now have the signals working when the parking lights are on and when the headlights are on. I still have no signals when the parking lamps/headlamps are off.

When the headlamps/parking lamps are off and I turn the blinker on, the the flasher relay does not fire. Any ideas? I'm pretty stumped.
Spacerz is offline  
post #6 of 6 Old 03-25-2014, 02:51 PM
Super Moderator

 
Heavy_GD's Avatar
 
Join Date: Aug 2013
Location: 804Va
Posts: 12,044
Mentioned: 66 Post(s)
Tagged: 1 Thread(s)
Quoted: 867 Post(s)
Thanks: 3,523
Thanked 832 Times in 777 Posts
Feedback Score: 3 reviews
start with the lights off and the signal on... check the posts on the relay for 12v at the switch and 12v at the source pin.

one of the two is interrupted.

GD - 06 CCSB FX4 Lariat
Quote:
Originally Posted by G8orFord View Post
My magic wand broke a few years back when my crystal ball fell on it. Ruined the ball too. So we're going to have to figure this one out another way. YOU NEED A MONITOR or at least a good scanner.
Heavy_GD is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome