No brake or turn signals, multi switch new, fuses good? - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 06-15-2013, 11:12 AM Thread Starter Fanatic
Join Date: Oct 2006
Posts: 91
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to ienjoydrifting
No brake or turn signals, multi switch new, fuses good?

On a trip and lost my turn signals and brake lights, the officer who wrote my ticket confirmed this!

Went to auto parts store and bought a new multifunction switch, didnt change anything. Checked all fuses, no blown.

Any other ideas?? Need to get this fixed so I can get home.

Also noticed the new multifunction switch is missing pins 379 and 380? Old one has them? Anyone know what those pin to?
ienjoydrifting is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome