Electrical Problems - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 07-18-2010, 06:38 AM Thread Starter
Member
 
Join Date: Sep 2009
Posts: 51
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Feedback Score: 0 reviews
Electrical Problems

So my issues may be related or completely seperate....
When I bought my truck (2000 7.3L Excusion) anytime I'd turn on the headlights, front wipers or turn signal, my rear wiper would turn on. I cheated the problem and disconnected the rear wiper motor. Now, 1 year later, when I turn on my headlights, the left turn signal arrow illuminates bright and the motor dies. If I turn on the windshield wipers they are very weak, and the left turn signal arrow on the dash illuminates but very dim. Just the running lights on causes the turn signal arrow to come on dim as well. I think there is some bleed over somerwhere. I read on here that the backside of the headlight switch is notorious for melting, I'll check that today. My question for you all... Any Ideas?
I hate shooting wires, so any help for a good starting point would be great!

Last edited by joker9r; 07-18-2010 at 02:21 PM. Reason: add text
joker9r is offline  
post #2 of 3 Old 08-03-2010, 07:39 PM Thread Starter
Member
 
Join Date: Sep 2009
Posts: 51
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Feedback Score: 0 reviews
Still cant seem to narrow down the short... does anyone have a good wiring diagram for the control column and/or headlight system???
joker9r is offline  
post #3 of 3 Old 09-07-2010, 05:37 AM Thread Starter
Member
 
Join Date: Sep 2009
Posts: 51
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Feedback Score: 0 reviews
Finally found my issue!!! On the wiring diagrams the left side of the dash and all of the left side lights, plus various other components including the fuel pump are all grounded just over the driverside wheel well. That ground was good so I looked further up found another ground point on the driverside upper firewall (which is not in any diagrams that I can find). The ground was completely loose and bolt missing. I have been having some smaller wierd querky problems like my rear windshield wiper turning on when my headlights were on or when I used my turn signal. I guess its been loose since i bought the truck and just recently the bolt fell out..
joker9r is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome