electrical...gauges,a/c,windows,radio intermittly stop working. - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-14-2010, 04:15 AM
Compression Ignition Addict
 

Join Date: Sep 2009
Location: Belton, MO
Posts: 335
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
electrical...gauges,a/c,windows,radio intermittly stop working.

Bought a 02 f250 cclb 2 days ago. driving it home to kansas city from baltimore. the battery light comes on and the gauges,a/c,windows,radio, stop working for few seconcds and everything goes back to nomal. First it was just occasionally then it was every 50 seconds, now there is no pattern. stopped in some town along the way at an advance auto to get the batterys checked. They said one needed replaced (driver side) so I have one new batery, and the Altinator is 1000 miles old.

Im assuming its a loose connection now, but as this is my first truck and diesel I don't know were to start looking...

Last edited by Cashflo; 06-14-2010 at 09:47 PM.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 06-14-2010, 09:51 PM
Compression Ignition Addict
 

Join Date: Sep 2009
Location: Belton, MO
Posts: 335
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Well, i think I found the problem. The previous owner took it to dealer to update any recalls. It had the speed controller recall. Well that little relay or whatever they put on it wasnt secured to anything. I found it laying on the exhaust manifold. Basicly anytime I hit over 2,250 rpm, the relay would short because the insulation was meted off a part of it.
Dealer dropped the relay off at previous owner, who mailed it to me, so I should get it in few days.

I hope this fixes the problem.
Reply With Quote Quick reply to this message
  #3  
Old 08-08-2010, 07:35 AM
Compression Ignition Addict
 

Join Date: Sep 2009
Location: Belton, MO
Posts: 335
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
still having problems. most of my driving has been has been through construction zone so ive mostly been doing 45-55
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 12:48 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors