electrical help please!!!! - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 11-29-2009, 10:25 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Oct 2007
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
electrical help please!!!!

I have a 2003 F250 PSD. Batteries went dead (3 mo old red optimas) hadn't driven it in about 4 weeks, went to start it and it tried to turn over then went completely dead... no power to anything. Charged batteries for about 3 hrs went out still had no dome light or hood light, decided to try and start it, only right side of dash lit up (abs, airbag, and such) no glow light... still tried to start it and it fired right up. I have no guages, no interior lights, no radio... seems to run and shift fine ( didn't drive it far due to no guages) checked all fuses with a test ligh and all show good... Headlights and running lights all work... any ideas????
Benzjed is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 11-29-2009, 10:28 AM
Compression Ignition Addict
 
ABoyAndHisToys's Avatar
 
Join Date: Feb 2008
Location: Bayville, NJ
Posts: 1,050
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Send a message via AIM to ABoyAndHisToys
Check the GEM box for corrosion. Has it been raining?

2001 CC Long Bed Fat A$$
New Heart w/Forged Rods @ 108,000miles (Damn PMR's).... with some goodies on it
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.




Brandon


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
ABoyAndHisToys is offline  
post #3 of 4 Old 11-29-2009, 11:20 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Oct 2007
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
I have no power windows, no instrument panel except for lights on right side, no radio, no interior lights, everything else seems to be working... I have door locks and cig lighter working, just drove it again and it seems to shift fine and had plenty of power...pulled fuse box and it looks clean... has been raining but truck stays inside shop. went back thru all fuses with a test light and all check good... I'm stumped
Benzjed is offline  
post #4 of 4 Old 06-23-2010, 12:04 PM
Powerstroke.org Rookie
 
Join Date: Jul 2007
Posts: 27
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Make sure the ignition switch is returning fully to the run position after cranking the engine. I had a ranger do that years ago....I could wiggle the key and it would all work again.
ambulance doctor is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome