Passenger side of truck without lights - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-03-2009, 07:18 PM
Powerstroke.org Rookie
 

Join Date: Nov 2009
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Passenger side of truck without lights

Hello,

My name is chris and I'm new to the forums but enough with that, All day today I been trying to figure out why on my 1988 F-350 7.3 One headlight works in the front (Drivers side), Both marker/Turn signal lights work, No tail lights, turn signal/break lamp on drivers side work. Everything works in cab and cabs lights work on top of cab. I've checked all the fuses all the wiring has no power clear up to fuse box, Checked with multi meter. Checked the bulbs and sockets. Please help need to go to work

Thanks so much
Chris

Last edited by Chris45601; 11-03-2009 at 07:22 PM.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 11-03-2009, 07:28 PM
Compression Ignition Addict
 

Join Date: Feb 2009
Location: Nacogdoches, TX
Posts: 11,036
Thanks: 0
Thanked 12 Times in 12 Posts
Feedback Score: 0 reviews
Well welcome. You'll love it. One day you're fixin it, the next you're puttin in gauges and mods
First did you mean 1998? I'm guessin so.
So you've got now power at the fuses in the dash? Check the fuses under the hood too.
Reply With Quote Quick reply to this message
  #3  
Old 11-03-2009, 08:20 PM
Powerstroke.org Rookie
 

Join Date: Nov 2009
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Nope, I mean 1988, 7.3 International, I do believe don't hold me to it, But i can't find the relay box under the hood
Reply With Quote Quick reply to this message
  #4  
Old 11-03-2009, 08:25 PM
Compression Ignition Addict
 

Join Date: Feb 2009
Location: Nacogdoches, TX
Posts: 11,036
Thanks: 0
Thanked 12 Times in 12 Posts
Feedback Score: 0 reviews
Oh ok. Wow, didn't know they had a 7.3 in that early a model.
Ok well then I'm lost. Sorry bud.
That year might not have had a relay box under there.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 11:55 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors