HELP WITH VEGGIE 7.3 ISSUES - Ford Powerstroke Diesel Forum
Bio-Diesel/Alternative Fuels and Supplements Bio-Diesel and related Discussion. Ask Questions and discuss what has worked for you here.

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-08-2008, 10:28 AM
Powerstroke.org Rookie
 

Join Date: Sep 2008
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
HELP WITH VEGGIE 7.3 ISSUES

I have about 2000 trouble free miles on veggie, until the other day. Basically whats happening is it runs great on diesel. If i switch it to veggie about 5 minutes later the engine starts to shake like crazy and dramatically loses power. Usually it will do this the first time I really get into the petal. If I switch it back to diesel, another five minutes and it runs fine again. The 5 minutes is how long Im guessing it takes my system to purge. I just replaced the on board veggie filter so my filter isnt clogged but other than that there isnt anything else I can think of the would impede the flow. Do you guys have any ideas? Please Help!!


I also have another question. I am getting pretty good quality oil and filtering through a home water filter. My filter on board gets clogged every 100 gallons or so even with me pre filtering it. What is wrong here, am I not filtering it enough? One guy I know has 15000 miles on his original veggie filter, and just puts it through a bag filter!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 10-08-2008, 10:46 AM
ADMIN AND TECH


 

Join Date: Oct 2006
Location: winston salem north carolina
Posts: 9,247
Thanks: 0
Thanked 4 Times in 4 Posts
Feedback Score: 0 reviews
i am by no means a veggie oil person, but if i had to guess , the veggie oil is to thick and the pump cant pump it , maybe you arent getting it clean enough
Reply With Quote Quick reply to this message
  #3  
Old 10-08-2008, 10:48 AM
Thats Mr. Oil Leak.....

 

Join Date: Oct 2006
Location: Cypress / Houston
Posts: 9,529
Thanks: 4
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to MrJohnWayne Send a message via MSN to MrJohnWayne Send a message via Yahoo to MrJohnWayne
Do you have a tank heater for the oil...

Hopefully CHenry will chime in here. He is the resident veggie expert.
Reply With Quote Quick reply to this message
  #4  
Old 10-08-2008, 11:35 AM
Powerstroke.org Rookie
 

Join Date: Sep 2008
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I do have a heated filter, heater in the tank, and a vegmax in the fuel line.
Reply With Quote Quick reply to this message
  #5  
Old 10-08-2008, 11:39 AM
I don't know nuttin....

 

Join Date: Jul 2006
Location: Tuttle, OK
Posts: 17,160
Thanks: 1
Thanked 9 Times in 9 Posts
Feedback Score: 0 reviews
Tell me all the details of your system...who made the kit would be a start - or is a home made. Wheatever the case, how does it operate stock pump or secondary pump, useing factory filter or no...etc.
Reply With Quote Quick reply to this message
  #6  
Old 10-08-2008, 11:44 AM
Member
 

Join Date: May 2008
Posts: 59
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
my guess would be air in the system. I ran out of veggie one time and it did exactly what you said. Look for leaks.

10K miles not problems.
Reply With Quote Quick reply to this message
  #7  
Old 10-08-2008, 12:01 PM
I don't know nuttin....

 

Join Date: Jul 2006
Location: Tuttle, OK
Posts: 17,160
Thanks: 1
Thanked 9 Times in 9 Posts
Feedback Score: 0 reviews
it does sound exactly like air, still, tell me how your system is made or who made it.
Check all the hose connections on the vaccume side of the pump...are you using a secondary pump?
Reply With Quote Quick reply to this message
  #8  
Old 10-08-2008, 12:02 PM
Compression Ignition Addict
 

Join Date: Dec 2006
Location: The "armpit" of Texas
Posts: 736
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Is this a home made system or did you buy a "kit"??? Need some details on your system.
Reply With Quote Quick reply to this message
  #9  
Old 10-08-2008, 04:05 PM
Powerstroke.org Rookie
 

Join Date: Sep 2008
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I did the same thing very badly 2 weeks ago even to the point at which it cut off and wouldnt start. I had to get it towed to the dealership and they said it was the fuel pump, so they replaced it. After I spent the money on the furl pump I realized that it was air in the system after all, not the pump. My veggie tank was low and sucking up some air. But now there is a good bit of veggie in the tank and it has started doing it again.

My system is a plantdrive system. I have a tank in the bed with a vormax heated filter and hotfox in the tank. Stock diesel filter was replaced with a metal slug to decrease purge times. A racor filter was put on the diesel only lines, basically taking place of the stock fuel filter. I also have a vegmax heater in the line right after the pump. The system uses my stock fuel pump.
Reply With Quote Quick reply to this message
  #10  
Old 10-08-2008, 04:22 PM
Banned
 

Join Date: Nov 2007
Location: Los Gatos CA
Posts: 733
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I have seen bag filters in 10, 5, and 2.5 (ml?). Most fuel filters are 10. So if a bag is getting the 2.5 and larger, it seems like it would prevent the fuel filter from clogging.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 05:46 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors