Horrible mpgs please help - Ford Powerstroke Diesel Forum
99-03 Ford Excursion Forum This forum is for topics relating to the Ford Excursion only.

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-03-2014, 09:01 PM
Member
 

Join Date: Mar 2012
Posts: 68
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Horrible mpgs please help

I have 01 ex 108 k that gets about 10-11 mpgs mixed city and hwy and 15 mpg hwy ... I use diesel kleen every fill up , have 4 inch turbo back no muff and air filter upgrade .... I cleaned out ebpv sensor and it made no diff ...no cel or codes showing ....33 inch tires and 2.5 inch lift .... What could i check or what am i missing here ? My 6.0 psd pickup gets 14 mpg mixed and 18 ish hwy so i expected simillar mpgs out of my 7.3
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 03-03-2014, 10:56 PM
Powerstroke.org Sponsor

 

Join Date: Apr 2010
Location: Defiance
Posts: 3,963
Thanks: 267
Thanked 69 Times in 67 Posts
Feedback Score: 1 reviews
Thats about normal this time of year. If you had some bigger injectors that would help and custom tunes.

Sent from AutoGuide.com Free App
Reply With Quote Quick reply to this message
  #3  
Old 03-04-2014, 10:19 AM
Member
 

Join Date: Mar 2012
Posts: 68
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I read claims of people getting simmilar or better than the 6.0s .... Since i have both , i can see an obvious difference .... Could i have a bad injector or 2 maybe?
Reply With Quote Quick reply to this message
  #4  
Old 03-04-2014, 10:20 AM
Member
 

Join Date: Mar 2012
Posts: 68
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Or is everyone that says that full of crap ? Lol
Reply With Quote Quick reply to this message
  #5  
Old 03-04-2014, 11:32 AM
Powerstroke.org Sponsor

 

Join Date: Apr 2010
Location: Defiance
Posts: 3,963
Thanks: 267
Thanked 69 Times in 67 Posts
Feedback Score: 1 reviews
Quote:
Originally Posted by SUPRA180 View Post
I read claims of people getting simmilar or better than the 6.0s .... Since i have both , i can see an obvious difference .... Could i have a bad injector or 2 maybe?
Very well could. Have you read through the stickies and have access to a very good diagnostic tool similar to AutoEnginuity?

Sent from AutoGuide.com Free App
Reply With Quote Quick reply to this message
  #6  
Old 03-04-2014, 04:31 PM
Powerstroke.org Fanatic
 

Join Date: Jul 2012
Location: Cedar City UT
Posts: 120
Thanks: 3
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
how heavy is your foot? Mine gets that when I'm lead footing it or towing, is it blowing black smoke? Is it warming up?
Reply With Quote Quick reply to this message
  #7  
Old 03-04-2014, 06:36 PM
Member
 

Join Date: Mar 2012
Posts: 68
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Warmed up or not and i know the heavy foot thing cuz of the 6oh .... I have yet for someone to check the injectors and stuff
Reply With Quote Quick reply to this message
  #8  
Old 03-04-2014, 07:35 PM
Compression Ignition Addict
 

Join Date: Apr 2012
Posts: 159
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Wow that's really bad. I am at 15-18 with mine on 35's in the city.
Reply With Quote Quick reply to this message
  #9  
Old 03-05-2014, 11:48 AM
Member
 

Join Date: Mar 2012
Posts: 68
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by 572ysc View Post
Wow that's really bad. I am at 15-18 with mine on 35's in the city.
Yea thats what im saying .....somethin def wrong ...
Reply With Quote Quick reply to this message
  #10  
Old 03-05-2014, 12:21 PM
Premium Member
 

Join Date: Jun 2012
Posts: 3,703
Thanks: 1
Thanked 17 Times in 17 Posts
Feedback Score: 0 reviews
It could just be the fuel you're using. I was experiencing horrible mileage until someone asked about my fuel. Second tank on better fuel (less bioblend), and my mileage is steadily getting back to where it was.
Reply With Quote Quick reply to this message
The Following User Says Thank You to Macon For This Useful Post:
hucorey (03-05-2014)
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 05:28 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors