problem w/00 excursion?! - Ford Powerstroke Diesel Forum
99-03 Ford Excursion Forum This forum is for topics relating to the Ford Excursion only.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 21 Old 11-30-2006, 10:05 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Nov 2006
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
problem w/00 excursion?!

hey guys im new here i usually spend my time on the lightning forums cause our excursion never had major problems,until now.what happened is my sister was driving it and was going 35 and she tried to accelerate, it would start shaking so she let off and it stopped.whe tried to accel. again and same thing.she then said she heard a noise.she cant explain the noise but said it was like POP or a SNAP and it lost power complitly even if she pressed the accelerator.so when i get there my my dad started it and we heard a CLANKING noise(constant over and over).the only way for me to explain it is when i blew a sparkplug on my Lightning, thats what it sounded like.it a 2000 ford 7.3L turbo diesel limited excursion.any help would be greatly appreciated!
lightning_2001 is offline  
Sponsored Links
Advertisement
 
post #2 of 21 Old 11-30-2006, 10:25 PM
Powerstroke Techie

 
djsdiesel's Avatar
 
Join Date: Nov 2006
Location: Moses Lake, WA
Posts: 723
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
got a check engine light??

99.5 F-250 PSD AT 4x4, 4in lift, 37 13.5 18 Pro comp Extreme A/T's, S&B Intake, GTP38R, DP Tuner custom programs (140 Agg., 120 sled pull, 80 tow and 60 tow), Rosewood DIY stage 2 injectors, BTS Trans, 5in exhaust no muffler, 6 oh intercooler, Ford AIC, EBPV delete, Foil delete, T/C lock up mod, Pusher Fuel Pump, Three Chime train Horns


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
djsdiesel is offline  
post #3 of 21 Old 11-30-2006, 11:06 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Nov 2006
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
yeah and also the oil and oil pressure.i checked engine oil trans. oil and coolants everything is good.when i try to start it, it acts like it normally should except it doesnt turn over.yall think maybe it could be the injectors?
lightning_2001 is offline  
post #4 of 21 Old 12-01-2006, 06:15 AM
Powerstroke Techie

 
djsdiesel's Avatar
 
Join Date: Nov 2006
Location: Moses Lake, WA
Posts: 723
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
i'd check for codes, it doesn't crank at all???

99.5 F-250 PSD AT 4x4, 4in lift, 37 13.5 18 Pro comp Extreme A/T's, S&B Intake, GTP38R, DP Tuner custom programs (140 Agg., 120 sled pull, 80 tow and 60 tow), Rosewood DIY stage 2 injectors, BTS Trans, 5in exhaust no muffler, 6 oh intercooler, Ford AIC, EBPV delete, Foil delete, T/C lock up mod, Pusher Fuel Pump, Three Chime train Horns


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
djsdiesel is offline  
post #5 of 21 Old 12-02-2006, 09:24 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Nov 2006
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
ok now it cranks over but it still makes the noise.i need a programmer for the codes right?
lightning_2001 is offline  
post #6 of 21 Old 12-03-2006, 07:33 PM
Powerstroke Techie

 
djsdiesel's Avatar
 
Join Date: Nov 2006
Location: Moses Lake, WA
Posts: 723
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
i would check codes, I don't know what your noiise is though. Is it pinging noise? or a knock? or??

99.5 F-250 PSD AT 4x4, 4in lift, 37 13.5 18 Pro comp Extreme A/T's, S&B Intake, GTP38R, DP Tuner custom programs (140 Agg., 120 sled pull, 80 tow and 60 tow), Rosewood DIY stage 2 injectors, BTS Trans, 5in exhaust no muffler, 6 oh intercooler, Ford AIC, EBPV delete, Foil delete, T/C lock up mod, Pusher Fuel Pump, Three Chime train Horns


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
djsdiesel is offline  
post #7 of 21 Old 12-04-2006, 09:34 PM
Premium Member
 
10.5stang's Avatar
 
Join Date: Sep 2006
Location: OKLAHOMA
Posts: 73
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
not sure

my 2000 limited excursion 4x4 did that about a month ago. it ran like crap and then it wouldnt run at all. i tried everthing and it was a pats module?
iam not sure what that is but i buddy of mine at the dealership fixed it.

08 6.4 CC SWB 4x4 6'' Fabtech, 37 nittos, Spartan, S&B intake,Deletes, 4'' MBRP Exhaust w/o muffler. More to come!
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
10.5stang is offline  
post #8 of 21 Old 12-04-2006, 10:44 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Nov 2006
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
djsdiesel the noise is like if you hit 2 pieces of 2x4 together over and over.its like a loud knock like metal (constant).thanks 10.5stang i dont know what a pats module is but you can bet imma look it up.
lightning_2001 is offline  
post #9 of 21 Old 12-04-2006, 10:54 PM
Powerstroke Techie

 
djsdiesel's Avatar
 
Join Date: Nov 2006
Location: Moses Lake, WA
Posts: 723
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Did you check codes yet?? Why wasn't it cranking? Is the theft light flashing while cranking?

99.5 F-250 PSD AT 4x4, 4in lift, 37 13.5 18 Pro comp Extreme A/T's, S&B Intake, GTP38R, DP Tuner custom programs (140 Agg., 120 sled pull, 80 tow and 60 tow), Rosewood DIY stage 2 injectors, BTS Trans, 5in exhaust no muffler, 6 oh intercooler, Ford AIC, EBPV delete, Foil delete, T/C lock up mod, Pusher Fuel Pump, Three Chime train Horns


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
djsdiesel is offline  
post #10 of 21 Old 12-05-2006, 01:07 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Nov 2006
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
it wouldnt crank at first but my dad said he got it to turn over.ill check for the theft light tomorrow.and no havent check codes.dont have a programmer.
lightning_2001 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome