Lurker joining the Excursion ranks.... - Ford Powerstroke Diesel Forum

99-03 Ford Excursion Forum This forum is for topics relating to the Ford Excursion only.

 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 01-23-2014, 06:44 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: May 2012
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Lurker joining the Excursion ranks....

Hey everyone. I really haven't had anything to post, normally I just do a search and all the information I need is found. For the past 2 years I had been looking for a 7.3 Excursion 4x4. Well I finally found and purchased the right one. A little bit about the X.
Its a 2001 7.3 4x4 with 118,000 miles, 6 position Ts Performance chip, 3.5" down pipe w/ 4" Exhaust, Ford HD air filter system and Viper Remote start security System.
Many things were done to the truck in the last year or so including updating the front end and adding Blistein shocks.I already know that I will be doing the 6.0 cooler mod and adding a digital monitoring gauge. Also I will be updating the Brakes on the truck.

I like the clean compact look of the digital setup and have a older Edge Insight on my f250 6.0 and has served me well. With the TS Performance chip would there be any conflict adding the Edge Insight CS? Or is anyone else running this combination? Also any recommendations on the brake update. the rotors are still in good shape. Really stoked to own this truck as it has been a long road finding a decent one with low miles!!
Thanks Mark
25contender is offline  
post #2 of 4 Old 01-23-2014, 09:00 AM
Compression Ignition Addict
 
ageekwithajeep's Avatar
 
Join Date: Jul 2012
Location: Cedar City UT
Posts: 189
Thanks: 4
Thanked 3 Times in 3 Posts
Mentioned: 0 Post(s)
Quoted: 2 Post(s)
Feedback Score: 0 reviews
Welcome to the site, glad you posted up and congrats on your new truck. Im sure answers will be flying in here soon as I'm not up on tuners.

2001 Ford Excursion

06 LJ rubicon
ageekwithajeep is offline  
post #3 of 4 Old 01-24-2014, 04:57 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: May 2012
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Quote:
Originally Posted by ageekwithajeep View Post
Welcome to the site, glad you posted up and congrats on your new truck. Im sure answers will be flying in here soon as I'm not up on tuners.
Thanks for the welcome.
25contender is offline  
post #4 of 4 Old 02-10-2014, 06:46 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: May 2012
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
I ended up installing the Edge Insight CS this past weekend. It was a very easy install. I did notice that there is no PID for the ECT. Has anyone installed a Temp Sensor for the Engine Coolant Temp? Just curious as to where you might have installed the sensor.
25contender is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome